alexshap added inline comments.

================
Comment at: lib/StaticAnalyzer/Core/SimpleSValBuilder.cpp:561
+      // manager to handle these comparisons.
+      if (BinaryOperator::isComparisonOp(op) &&
+          rhs.getSubKind() == nonloc::SymbolValKind) {
----------------
some thoughts - evalBinOpNN is already pretty gigantic (300+ locs), 
imo it might be useful to reorganize the code (at least the newly added one) to 
improve readability.  
i.e. since a partial case (isSignedIntegerOrEnumerationType) is under 
consideration here,
probably it would be good (where it's reasonable) to move some details into a 
helper function/method.


https://reviews.llvm.org/D35109



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to