lebedev.ri added inline comments.

================
Comment at: clang-tidy/readability/FunctionSizeCheck.cpp:38
+    } else {
+      assert(!isa<CompoundStmt>(Node));
+      if (TrackedParent.back())
----------------
malcolm.parsons wrote:
> I don't think this assert adds anything.
Yes, however the original `if` did have that check.
I **think**, having an assert here may help to not break this in the future.


Repository:
  rL LLVM

https://reviews.llvm.org/D34202



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to