krasimir added a comment. I feel that this is a bit too rough now; any suggestions on improving the architecture/design of this patch are welcome!
================ Comment at: lib/Format/UnwrappedLineParser.cpp:2206 + const SmallVectorImpl<FormatToken *> &Comments, + const FormatToken* NextTok) { bool CommentsInCurrentLine = true; ---------------- Any suggestions on how to improve the code quality a bit if we stick with this design? ================ Comment at: lib/Format/UnwrappedLineParser.h:118 + void organiseComments(const SmallVectorImpl<FormatToken *> &Comments, + const FormatToken *NextTok); void flushComments(bool NewlineBeforeNext); ---------------- @djasper: considering what this code does, what would be a better name of this? https://reviews.llvm.org/D29626 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits