Eugene.Zelenko added a comment. I think will be good idea to extend check for class members.
================ Comment at: test/clang-tidy/readability-one-name-per-declaration-modern.cpp:13 + public: + vector() {} + vector(initializer_list<T> init) {} ---------------- Please use = default; Same below. ================ Comment at: test/clang-tidy/readability-one-name-per-declaration-modern.cpp:25 + namespace string_literals { + + string operator""s(const char*, decltype(sizeof(int))) ---------------- Please remove empty line. ================ Comment at: test/clang-tidy/readability-one-name-per-declaration-modern.cpp:34 +namespace Types { + + typedef int MyType; ---------------- Please remove empty line. https://reviews.llvm.org/D27621 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits