djasper added inline comments.
================ Comment at: clang-tidy/readability/ElseAfterReturnCheck.cpp:28 stmt(forEach( - ifStmt(hasThen(stmt( + ifStmt(unless(hasParent(ifStmt())), + hasThen(stmt( ---------------- I think this now effectively does: stmt(forEach(ifStmt(unless(hasParent(ifSttmt())), ...) I think that's equivalent to: stmt(unless(ifStmt()), forEach(ifStmt(...))) https://reviews.llvm.org/D26125 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits