ast added inline comments.
================ Comment at: llvm/lib/Target/BPF/BPFInstrInfo.td:56 def BPFNoALU32 : Predicate<"!Subtarget->getHasAlu32()">; +def BPFHasCPUv4_ldsx : Predicate<"Subtarget->getCPUv4_ldsx()">; +def BPFHasCPUv4_movsx : Predicate<"Subtarget->getCPUv4_movsx()">; ---------------- Here and elsewhere... let's drop CPUv4 mid prefix. imo the extra verbosity doesn't improve readability. Same with the flag: disable-cpuv4-movsx. I can be disable-movsx. s/BPFHasCPUv4_ldsx/BPFHasLdsx/ s/getCPUv4_bswap/getHasBswap/ or even shorter hasBswap ? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D144829/new/ https://reviews.llvm.org/D144829 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits