craig.topper added inline comments.
================ Comment at: llvm/lib/Target/RISCV/RISCVInstrInfo.cpp:14 #include "RISCVInstrInfo.h" +#include "MCTargetDesc/RISCVBaseInfo.h" #include "MCTargetDesc/RISCVMatInt.h" ---------------- RISCV.h already includes this. ================ Comment at: llvm/lib/Target/RISCV/RISCVInstrInfo.cpp:2517 + case CASE_WIDEOP_OPCODE_LMULS_MF4(FWSUB_WV): { + assert(RISCVII::hasVecPolicyOp(MI.getDesc().TSFlags) && + MI.getNumExplicitOperands() == 7 && ---------------- This is a lot of code duplication. Can't we add a couple ifs to the existing code? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D154629/new/ https://reviews.llvm.org/D154629 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits