dblaikie added inline comments. ================ Comment at: lib/Sema/SemaOverload.cpp:12996 @@ +12995,3 @@ + // selection expression. + std::vector<Expr *> AssocExprs(GSE->getAssocExprs().vec()); + unsigned ResultIdx = GSE->getResultIndex(); ---------------- george.burgess.iv wrote: > Is there a reason this isn't a `SmallVector` instead? Another note on this - we should generally prefer copy init over direct init (less power, less responsibility/easier to read):
std::vector<Expr*> AssocExprs = GSE->getAssocExprs().vec(); (& as for George's question: since ArrayRef::vec returns std::vector, it's cheaper to store in a std::vector (by move) than to make a copy into a SmallVector) https://reviews.llvm.org/D24152 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits