erichkeane added a comment. Just 2 small nits, otherwise this all LGTM.
================ Comment at: clang/lib/Parse/ParseDecl.cpp:430 + } + if (Expr.isInvalid()) { + SawError = true; ---------------- Please put a newline between unchained 'if' statements... it makes tehse really hard to read without it. It happens a few times here. ================ Comment at: clang/lib/Sema/SemaDeclAttr.cpp:878 - if (!isIntOrBool(AL.getArgAsExpr(0))) { + Expr *First = AL.getArgAsExpr(0); + if (!isIntOrBool(First)) { ---------------- Unrelated change here? What is this for? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D105759/new/ https://reviews.llvm.org/D105759 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits