0x59616e added inline comments.
================ Comment at: clang/lib/Frontend/CompilerInvocation.cpp:559 + emitError |= DefaultCC == LangOptions::DCC_StdCall && + !(Arch == llvm::Triple::m68k || Arch == llvm::Triple::x86); emitError |= (DefaultCC == LangOptions::DCC_VectorCall || ---------------- nit: Is the expanded one better in terms of readability ? ================ Comment at: clang/test/CodeGen/mrtd.c:9 +// X86: define{{.*}} x86_stdcallcc void @foo(i32 noundef %arg) [[NUW:#[0-9]+]] +// M68k: define{{.*}} cc104 void @foo(i32 noundef %arg) void foo(int arg) { ---------------- Just curious, why do we have to use such an arcane name instead of a more lucid one , such as `m68k_rtdcc`. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D149867/new/ https://reviews.llvm.org/D149867 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits