sammccall accepted this revision. sammccall added inline comments. This revision is now accepted and ready to land.
================ Comment at: clang-tools-extra/clangd/Preamble.cpp:216 unsigned Offset; + tok::PPKeywordKind Directive; + // Name of the macro being defined in the case of a #define directive. ---------------- initialize to pp_unknown ================ Comment at: clang-tools-extra/clangd/unittests/PreambleTests.cpp:678 // Check ranges for notes. - Annotations NewCode(("#define [[BARXYZ]] 1\n" + BaselinePreamble + + Annotations NewCode(("#define BARXYZ 1\n" + BaselinePreamble + "void foo();\n#define [[FOO]] 2") ---------------- as elsewhere, I think this writing this as a single raw string without reusing BaselinePreamble is easier to follow ================ Comment at: clang-tools-extra/clangd/unittests/PreambleTests.cpp:684 EXPECT_THAT(mainFileDiagRanges(*AST), - UnorderedElementsAre(NewCode.ranges()[0], NewCode.ranges()[2])); + UnorderedElementsAre(NewCode.ranges()[1])); } ---------------- named ranges Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143093/new/ https://reviews.llvm.org/D143093 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits