xgupta marked an inline comment as done. xgupta added inline comments.
================ Comment at: clang/include/clang/APINotes/Types.h:535 NullabilityPayload &= - ~(NullabilityKindMask << (index * NullabilityKindSize)); + ~(static_cast<uint64_t>NullabilityKindMask << (index * NullabilityKindSize)); ---------------- aaron.ballman wrote: > I think a cleaner way to solve this is to make `NullabilityKindMask` be > 64-bits. None of the other operations need this change, but it seems like it > will be a bit more future-proof that way. WDYT? Yeah, I do agree. Thanks for the suggestion. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D142334/new/ https://reviews.llvm.org/D142334 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits