dcoughlin added a comment.

Other than a naming/documentation suggestion, looks good to me. Thanks Gábor!


================
Comment at: lib/StaticAnalyzer/Core/ExprEngineC.cpp:424
@@ +423,3 @@
+        if (!val.isZeroConstant()) {
+          val = getStoreManager().evalDynamicCast(val, T, Failed);
+        }
----------------
It seems a bit weird to call a method named "evalDynamicCast" when handling a 
static cast. What do you think about renaming evalDynamicCast() to to 
attemptDowncast() and updating its documentation to reflect its now-dual use?


https://reviews.llvm.org/D23014



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to