ilya-biryukov accepted this revision. ilya-biryukov added a comment. This revision is now accepted and ready to land.
Thanks, LGTM! ================ Comment at: clang/include/clang/Sema/Sema.h:7101 + void addInitCapture(sema::LambdaScopeInfo *LSI, VarDecl *Var, + bool isReferenceType); ---------------- NIT 1: naming, this should be in `UpperCamelCase` NIT 2: maybe rename to `ByRef`? It might be a bit confusing to talk about types here as the idea is to actually pass information about the syntax. Types can be inspected by looking at `Var`. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D139125/new/ https://reviews.llvm.org/D139125 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits