DavidSpickett accepted this revision. DavidSpickett added a comment. This revision is now accepted and ready to land.
Looks like a good direction to me. Plenty more bits in clang that should really live in the target parser, and this is a great start at moving those. My only issue is the use of `AI` for ArchInfo. I see that ArchKind was also a type and a var name. If this new name is following the codestyle then fine but I'd go with ArchInfo (`arch_info` but that's against the style, sigh). Up to you, I know the acronym style is common elsewhere and IDE helpers mitigate it somewhat. ================ Comment at: llvm/include/llvm/Support/AArch64TargetParser.h:119 + ArchInfo(const ArchInfo &) = delete; + ArchInfo &operator=(const ArchInfo &rhs) = delete; + ---------------- Do you need to do anything to prevent moving from this? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D138792/new/ https://reviews.llvm.org/D138792 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits