shafik added inline comments.
================ Comment at: clang/lib/Basic/SourceManager.cpp:2251 + uint64_t CountedSize = 0; + for (int IDIndex = -(int)LoadedSLocEntryTable.size() - 1; + IDIndex < (int)LocalSLocEntryTable.size(); ++IDIndex) { ---------------- alexfh wrote: > Could you add a comment about the meaning of negative IDIndex values? Maybe make `-(int)LoadedSLocEntryTable.size()` a named variable may help readability as well. Perhaps also for `(int)LocalSLocEntryTable.size()` as well. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D137751/new/ https://reviews.llvm.org/D137751 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits