erichkeane accepted this revision. erichkeane added a comment. This revision is now accepted and ready to land.
This seems right to me, thanks! I'm currently pushing to try to make our diagnostics 'check' lines more readable... it doesn't gain a ton in this case, but more to try to push for consistency. ================ Comment at: clang/test/CXX/drs/dr26xx.cpp:7 +struct foo { + constexpr foo() requires (!A && !B) = delete; // expected-note {{marked deleted here}} + constexpr foo() requires (A || B) = delete; ---------------- ================ Comment at: clang/test/CXX/drs/dr26xx.cpp:12 +void f() { + foo fooable; // expected-error {{call to deleted}} +} ---------------- Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D134145/new/ https://reviews.llvm.org/D134145 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits