rnk added inline comments.
================ Comment at: clang/lib/CodeGen/TargetInfo.cpp:1781 + + return (Ty->isIntegralOrEnumerationType() || Ty->isPointerType() || + Ty->isReferenceType()); ---------------- I think we could improve readability here with some named variable booleans and by avoiding the lambda. These come to mind: bool IsPtrOrInt = bool CCUsesInReg = ... Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D133920/new/ https://reviews.llvm.org/D133920 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits