sdesmalen added inline comments.
================ Comment at: clang/lib/CodeGen/CGBuiltin.cpp:9077 +Value *CodeGenFunction::EmmitSVESetTuples(const SVETypeFlags &TypeFlags, + llvm::Type *Ty, ---------------- nit: s/Emmit/Emit/ How about naming these: * EmitSVETupleGet * EmitSVETupleSet * EmitSVETupleCreate ================ Comment at: clang/lib/CodeGen/CGBuiltin.cpp:9084 + auto *SrcTy = dyn_cast<llvm::VectorType>(Ops[2]->getType()); + unsigned int I = cast<ConstantInt>(Ops[1])->getSExtValue() * + SrcTy->getElementCount().getKnownMinValue(); ---------------- nit: s/unsigned int/unsigned/ ================ Comment at: clang/lib/CodeGen/CGBuiltin.cpp:9091 + +Value *CodeGenFunction::EmmitSVEGetTuples(const SVETypeFlags &TypeFlags, + llvm::Type *Ty, ---------------- nit: Can this function be merged with the function above, you could pass `bool IsInsert`? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D131547/new/ https://reviews.llvm.org/D131547 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits