wyt added a comment. In D127745#3582085 <https://reviews.llvm.org/D127745#3582085>, @sgatev wrote:
> On a high level, what's wrong with having `getPointeeLoc` members with > different return types in `ReferenceValue` and `PointerValue`? IMO, it would be nice to distinguish the type of Value we are working on. As per Dmitri's suggestion, I updated the patch so that getPointeeLoc of ReferenceValue is now renamed to getReferentLoc, getPointeeLoc is remains the same for PointerValue. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127745/new/ https://reviews.llvm.org/D127745 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits