martong accepted this revision.
martong added a comment.
This revision is now accepted and ready to land.

LGTM



================
Comment at: clang/lib/StaticAnalyzer/Core/SValBuilder.cpp:447
   case nonloc::ConcreteIntKind:
-    return val.castAs<nonloc::ConcreteInt>().evalMinus(*this);
+    return makeIntVal(-X.castAs<nonloc::ConcreteInt>().getValue());
   case nonloc::SymbolValKind:
----------------
Maybe it's just me, but for me it is easier to read with surrounding 
parentheses.
Same below.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D127734/new/

https://reviews.llvm.org/D127734

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to