yihanaa added inline comments.

================
Comment at: clang/lib/CodeGen/CGBuiltin.cpp:2048
                                LValue RecordLV, CharUnits Align,
-                               llvm::FunctionCallee Func, int Lvl) {
+                               bool dumpTypeName, llvm::FunctionCallee Func,
+                               int Lvl) {
----------------
erichkeane wrote:
> Not a fan of bool parameters, they make calls harder to read.
I can add comments for this parameter or this function, what do you think, or 
do you have a better idea? I would like to improve it.


================
Comment at: clang/lib/CodeGen/CGBuiltin.cpp:2141
+      TmpRes =
+          dumpRecord(CGF, CanonicalType, FieldLV, Align, false, Func, Lvl + 1);
       Res = CGF.Builder.CreateAdd(TmpRes, Res);
----------------
erichkeane wrote:
> 
Agree!I will modify it later


================
Comment at: clang/lib/CodeGen/CGBuiltin.cpp:2705
     LValue RecordLV = MakeAddrLValue(RecordPtr, Arg0Type, Arg0Align);
-    Value *Res = dumpRecord(*this, Arg0Type, RecordLV, Arg0Align,
+    Value *Res = dumpRecord(*this, Arg0Type, RecordLV, Arg0Align, true,
                             {LLVMFuncType, Func}, 0);
----------------
erichkeane wrote:
> 
Agreeļ¼


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D122920/new/

https://reviews.llvm.org/D122920

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to