erichkeane added inline comments.
================ Comment at: clang/include/clang/Basic/DiagnosticASTKinds.td:69 +def note_constexpr_static_local : Note< + "control flows through the declaration of a %select{static|thread_local}0 variable">; def note_constexpr_subobject_declared_here : Note< ---------------- aaron.ballman wrote: > erichkeane wrote: > > Hmm... this feels a little awkward to me. Though, I usually have Aaron do > > the bikeshedding, so if he didn't come up with better I guess we can let it > > go. > I didn't think it was overly awkward, about the only question I had was > "should we quote the `static` and `thread_local` as keywords?" when I > reviewed. Ok, I can live with that. AS far as quoting, I think we are consistently inconsistent on that one. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D111400/new/ https://reviews.llvm.org/D111400 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits