ZarkoCA marked 8 inline comments as done. ZarkoCA added inline comments.
================ Comment at: clang/lib/Sema/SemaChecking.cpp:5255 + const auto *PVD = dyn_cast<ParmVarDecl>( + (dyn_cast<DeclRefExpr>( + (dyn_cast<ImplicitCastExpr>(Arg->IgnoreParens()))->getSubExpr())) ---------------- sfertile wrote: > I find these longer lines hard to read. I way you had the original checks > structured was good, my suggestion was really meant to change only the > nesting. I think keeping the same format you would have ended up with > something that looks like > > ``` > const auto *ICE = dyn_cast<ImplicitCastExpr>(Arg->IgnoreParens()); > if (!ICE) > return; > > const auto *DR = dyn_cast<DeclRefExpr>(ICE->getSubExpr()); > if (!DR) > return; > > auto *PD = dyn_cast<ParmVarDecl>(DR->getDecl(); > if (!PD || !PD->getType()->isRecordType()) > return; > ``` > I agree I find it easier to read this way as well. Thanks for clearing that up. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D118350/new/ https://reviews.llvm.org/D118350 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits