qiucf added inline comments.

================
Comment at: clang/lib/Basic/Targets/PPC.cpp:425
 
+  Features["isa207"] = llvm::StringSwitch<bool>(CPU)
+                           .Case("pwr9", true)
----------------
Will it be better if name to `isa2_07`, `isa3_0` to make it less confusing?

Besides, in backend we have subtarget features `isa-v30-instructions` and 
`isa-v31-instructions` but they're not present at frontend, we should pass 
these feature flags to backend correctly.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D105501/new/

https://reviews.llvm.org/D105501

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to