rnk added a comment. Seems reasonable, but we still need a small IR test.
================ Comment at: llvm/lib/CodeGen/AsmPrinter/CodeViewDebug.cpp:807 // TODO: Figure out which other flags need to be set. + if (MMI->getModule()->getProfileSummary(/* IsCS */ false) != nullptr) { + Flags |= static_cast<uint32_t>(CompileSym3Flags::PGO); ---------------- nit, the more common style to name parameters looks like `getProfileSummary(/*IsCS=*/false)`. Sort of more Python-y. ================ Comment at: llvm/lib/CodeGen/AsmPrinter/CodeViewDebug.cpp:1434 FPO |= FrameProcedureOptions::OptimizedForSpeed; + if (GV.getEntryCount().hasValue()) { + FPO |= FrameProcedureOptions::ValidProfileCounts; ---------------- I think the preferred spelling is `GV.hasProfileData()`, I think that's functionally equivalent. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D99994/new/ https://reviews.llvm.org/D99994 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits