steakhal accepted this revision.
steakhal added a comment.

`Unused code` seems to be broader and probably a better fit for a generic //bug 
category//.



================
Comment at: clang/lib/StaticAnalyzer/Checkers/DeadStoresChecker.cpp:263-264
 
-    BR.EmitBasicReport(AC->getDecl(), Checker, BugType, "Dead store", os.str(),
-                       L, R, Fixits);
+    BR.EmitBasicReport(AC->getDecl(), Checker, BugType, categories::UnusedCode,
+                       os.str(), L, R, Fixits);
   }
----------------
This is the only case where I think it's debatable.
However, I have no better option, and I'm still in favor of your change.


Repository:
  rC Clang

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98741/new/

https://reviews.llvm.org/D98741

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to