jansvoboda11 added a comment. In D96847#2576369 <https://reviews.llvm.org/D96847#2576369>, @dexonsmith wrote:
> In D96847#2574408 <https://reviews.llvm.org/D96847#2574408>, @jansvoboda11 > wrote: > >> That's a bit nicer. >> >> Not sure if `RemarkPattern` is a good name now, as it may represent an >> optimization remark that doesn't have any pattern associated with it. >> How about calling it `OptimizationRemark` and merging `operator bool` and >> `operator ->` into `bool patternMatch(...) { return Pattern && >> Pattern.match(...); }`? > > Seems reasonable. Or `matchesPattern(...)`? I chose `patternMatches`, which (IMO) suggests the pattern is contained within the object and the string to be matched is passed as an argument. To me, `matchesPattern` sounds like it's the other way around, which would contradict the code. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96847/new/ https://reviews.llvm.org/D96847 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits