steveire added inline comments.

================
Comment at: 
clang-tools-extra/clang-tidy/readability/RedundantSmartptrGetCheck.cpp:21-45
+  return expr(
+             anyOf(cxxMemberCallExpr(
+                       on(expr(anyOf(hasType(OnClass),
+                                     hasType(qualType(pointsTo(
+                                         decl(OnClass).bind("ptr_to_ptr"))))))
+                              .bind("smart_pointer")),
+                       unless(callee(
----------------
njames93 wrote:
> The patch says its simplifying the check, but this doesn't look like its 
> simplifying it. Seems to be extending it to support dependent members.
Changed the description.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D96222/new/

https://reviews.llvm.org/D96222

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
  • [PATCH] D96222: Handle unins... Stephen Kelly via Phabricator via cfe-commits

Reply via email to