djasper marked 3 inline comments as done. ================ Comment at: clang-tidy/misc/MiscTidyModule.cpp:123 @@ -121,1 +122,3 @@ + CheckFactories.registerCheck<UnusedUsingDeclsCheck>( + "misc-unused-using-decls"); CheckFactories.registerCheck<VirtualNearMissCheck>( ---------------- alexfh wrote: > I think, all "misc-unused-" checks except for the "misc-unused-raii" (which > finds actual bugs) mostly relate to readability. I suggest placing the new > check to readability/ and we'll then move the other two "misc-unused-" checks > there as well. I am not really certain that "readability" is a reasonable category for unused things. Maybe unused should be its own category? At any rate, I think we should move all of them at the same time and not now go ahead and create a weird intermediate state.
================ Comment at: clang-tidy/misc/UnusedUsingDeclsCheck.cpp:23 @@ +22,3 @@ + Finder->addMatcher(usingDecl(isExpansionInMainFile()).bind("using"), this); + Finder->addMatcher(recordType(hasDeclaration(namedDecl().bind("used"))), + this); ---------------- alexfh wrote: > Why is it necessarily a `recordType`? How about typedefs and enums? I'd like to handle those as a follow-up. We only track using declarations of Records at the moment in the callback, too. http://reviews.llvm.org/D19259 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits