dylanmckay added inline comments.
================ Comment at: clang/lib/Driver/ToolChains/AVR.cpp:40 +llvm::Optional<unsigned> GetMcuSectionAddressData(StringRef MCU) { + return llvm::StringSwitch<llvm::Optional<unsigned>>(MCU) ---------------- benshi001 wrote: > aykevl wrote: > > I don't think the LLVM coding style says something about this, but coming > > from Go I'm more used to capitalized abbreviations (`MCU`, > > `GetMCUSectionAddressData`). > > > > However, this is just a superficial thing, feel free to ignore. > I prefer to "Mcu" I will change, thanks for the suggestions. FWIW, Rust prefers the `Mcu` variant IIRC which is where I adapted this pattern Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86629/new/ https://reviews.llvm.org/D86629 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits