JDevlieghere added inline comments.
================ Comment at: clang/lib/Basic/SourceManager.cpp:705 +llvm::Optional<llvm::MemoryBufferRef> +SourceManager::getMemoryBufferForFileOrNone(const FileEntry *File) { const SrcMgr::ContentCache *IR = getOrCreateContentCache(File); ---------------- Would it make sense to rename this to the slightly less verbose `getMemoryBufferOrNone` now that it takes just the File as an argument? Or maybe even `getBufferOrNone` like the method in `ContentCache`. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89429/new/ https://reviews.llvm.org/D89429 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits