usaxena95 added inline comments.
================ Comment at: clang-tools-extra/clangd/Quality.h:129 + // Properties and utilites used to compute derived signals. These are ignored + // by a scoring function. Must be explicitly assigned. ---------------- sammccall wrote: > Why is it better to group the fields acconding to how they're used in the > scoring function, rather than by what they mean? > (I find the new grouping harder to follow) I intended to separate out the concrete signals from properties/utilities used to calculate other derived signals. I agree the previous grouping made it makes it easier to follow the meaning of these. So reverted it. ================ Comment at: clang-tools-extra/clangd/Quality.h:155 + + void calculateDerivedSignals(); + ---------------- sammccall wrote: > why must this be called explicitly rather than being computed by Evaluate? Now evaluate() calls this. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D79500/new/ https://reviews.llvm.org/D79500 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits