martong added a comment.

In D84415#2215780 <https://reviews.llvm.org/D84415#2215780>, @vsavchenko wrote:

> Off-topic: I really think that we should have some sort of DSL for that kind 
> of stuff.

In a sense the API provided in the Checker itself is an (embedded) DSL. Or do 
you think about being able to provide the summaries by describing them in a 
JSON or a YAML file?



================
Comment at: 
clang/lib/StaticAnalyzer/Checkers/StdLibraryFunctionsChecker.cpp:2013
+    if (Pthread_tTy) {
+      Pthread_tPtrTy = ACtx.getPointerType(*Pthread_tTy);
+      Pthread_tPtrRestrictTy = getRestrictTy(*Pthread_tPtrTy);
----------------
vsavchenko wrote:
> It feels like the readability of the code here can be drastically improved by 
> introducing functions `getPointerType`, `getRestrictType`, and similar 
> accepting `Optional` arguments. 
Yeah, we already have `getRestrictTy`, but never though to have `getPointerTy`, 
which indeed simplifies the code, thanks!


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D84415/new/

https://reviews.llvm.org/D84415

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to