gribozavr2 added inline comments.
================ Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:124 +static void +populateNaimgStyle(std::vector<IdentifierNamingCheck::OptionalStyle> &Styles, + const ClangTidyCheck::OptionsView &Options) { ---------------- I think it would be better to return the vector by value. ================ Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.h:62 + using OptionalStyle = llvm::Optional<NamingStyle>; + ---------------- I'd suggest to inline the definition of this typedef, because it makes code more obscure for the benefit of shortening the name by a couple of characters. ================ Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.h:76 + + mutable llvm::StringMap<std::vector<OptionalStyle>> NamingStylesCache; + ---------------- It would be nice to add the comment that explains what the keys for the map and the vector are. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84814/new/ https://reviews.llvm.org/D84814 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits