dang marked 4 inline comments as done.
dang added inline comments.

================
Comment at: clang/include/clang/Serialization/ASTBitCodes.h:396-400
       /// Record code for the signature that identifiers this AST file.
       SIGNATURE = 1,
 
+      /// Record code for the signature of the AST block.
+      AST_SIGNATURE,
----------------
dexonsmith wrote:
> These names and descriptions hard hard to differentiate. Is there another way 
> of naming these that will be more clear?
> 
> (One idea I had is to create `CONTROL_BLOCK_HASH` and `AST_BLOCK_HASH` and 
> then `SIGNATURE` could just be their hash-combine, but maybe you have another 
> idea.)
I kept the same hasher when computing both of these which mitigates the cost. I 
don't see the need for also emitting a hash for the control block, there are 
some optional records that are not in both the AST block and the control block 
anyway.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D80383/new/

https://reviews.llvm.org/D80383



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to