sdesmalen accepted this revision. sdesmalen added a comment. This revision is now accepted and ready to land.
LGTM! ================ Comment at: clang/lib/CodeGen/CGBuiltin.cpp:5830 BuiltinID == NEON::BI__builtin_neon_vqrdmulhq_lane_v) - RTy = llvm::VectorType::get(Ty->getVectorElementType(), - Ty->getVectorNumElements() * 2); + RTy = llvm::VectorType::get(cast<llvm::VectorType>(Ty)->getElementType(), + cast<llvm::VectorType>(Ty)->getNumElements() * ---------------- nit: Can you pull this into a separate variable so you only have to cast once? (possibly RTy can be re-used for this) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D77257/new/ https://reviews.llvm.org/D77257 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits