vabridgers marked 6 inline comments as done. vabridgers added a comment. I believe all comments have been addressed. Please let me know if there's anything else required. Thanks
================ Comment at: clang/lib/StaticAnalyzer/Checkers/StdLibraryFunctionsChecker.cpp:519 + // architectures, but not for others. + const RangeInt UCharMax = + std::min(BVF.getMaxValue(ACtx.UnsignedCharTy).getLimitedValue(), IntMax); ---------------- NoQ wrote: > Let's rename this constant then, so that we still had our `UCharMax` when we > actually need the real `UCHAR_MAX` in the summary. Done, thanks Artem. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D75529/new/ https://reviews.llvm.org/D75529 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits