baloghadamsoftware added inline comments.
================ Comment at: clang/lib/StaticAnalyzer/Checkers/StreamChecker.cpp:43 + EofError, /// EOF condition (`feof` is true). + OtherError, /// Other (non-EOF) error (`ferror` is true). + AnyError /// EofError or OtherError, used if exact error is unknown. ---------------- baloghadamsoftware wrote: > balazske wrote: > > Szelethus wrote: > > > Shouldn't we call this `FError` instead, if this is set precisely when > > > `ferror()` is true? Despite the comments, I still managed to get myself > > > confused with it :) > > Plan is to rename to `NoError`, `FEofError`, `FErrorError`, > > `FEofOrFErrorError`. > If would suggest `NoError`, `FEoF`, `FError`, `FEoFOrFError`. Too many > `Error` suffixes reduce the readability. I suggest to omit the last error state in this patch and introduce it in the patch which uses it. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D75682/new/ https://reviews.llvm.org/D75682 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits