kfunk added inline comments.

================
Comment at: tools/libclang/CXType.cpp:990
@@ -987,1 +989,3 @@
 
+CXType clang_getNamedTypeUnderlyingElaboratedType(CXType CT){
+  QualType T = GetQualType(CT);
----------------
I'm not happy with this name either. If you look through the libclang API, 
functions are named like `clang_get${CPPCLASSNAME}${CPPMETHOD}`. E.g. 
`clang_getEnumConstantDeclValue`, `clang_getFieldDeclBitWidth`, 
`clang_getFunctionTypeCallingConv`.

Sergey's initial version was closer to that. Maybe 
`clang_getElaboratedTypeNamedType` will just do...?


http://reviews.llvm.org/D11797



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to