ilya-biryukov added inline comments.
================ Comment at: clang-tools-extra/clangd/clients/clangd-vscode/src/semantic-highlighting.ts:128 + this.highlighter.highlight( + vscode.Uri.parse(params.textDocument.uri).toString(), lines); } ---------------- Could we accept a `URI` in the `highlight` (and similar function in highlighting) instead and compare the URIs instead of strings in the `Highlighter.applyHighlightings`? i.e. in code: ``` fileUri : string; if (e.document.uri.toString() !== fileUri) return; ``` Could instead be: ``` fileUri : Uri; if (e.document.uri.toString() !== fileUri.toString()) return; ``` This should normalize accordingly and is generally safer and more readable than passing around strings. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D69996/new/ https://reviews.llvm.org/D69996 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits