NoQ added inline comments.
================ Comment at: clang/lib/StaticAnalyzer/Core/RegionStore.cpp:630 + (const RegionBindings::TreeTy *)((uintptr_t)store & ~(uintptr_t)1), + RBFactory.getTreeFactory(), (bool)((uintptr_t)store & (uintptr_t)1)); } ---------------- xazax.hun wrote: > baloghadamsoftware wrote: > > `(uintptr_t)1` look like a bit like some kind of magic number. Could we > > define it as a constant instead? > Or maybe this can be abstracted away using `llvm::PointerIntPair`? > Or maybe this can be abstracted away using `llvm::PointerIntPair`? !!! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D65361/new/ https://reviews.llvm.org/D65361 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits