jfb marked 4 inline comments as done.
jfb added inline comments.

================
Comment at: clang/include/clang/Driver/Options.td:2010
   HelpText<"Overlay the virtual filesystem described by file over the real 
file system">;
+def ivfsmode : Joined<["-"], "ivfsmode=">, Group<clang_i_Group>, 
Flags<[CC1Option, HelpHidden]>,
+  HelpText<"Use the virtual file system in 'real' mode, or 'physical' mode. In 
'real' mode the working directory is linked to the process' working directory. 
In 'physical' mode it has its own working directory, independent of (but 
initially equal to) that of the process.">,
----------------
sammccall wrote:
> Referring to this as `vfs`/"use the virtual file system..." seems possibly 
> misleading, as we're talking about how we're using the *real* filesystem 
> (through the virtual interface)
🤷‍♂️

Let's discuss below.


================
Comment at: clang/include/clang/Driver/Options.td:2012
+  HelpText<"Use the virtual file system in 'real' mode, or 'physical' mode. In 
'real' mode the working directory is linked to the process' working directory. 
In 'physical' mode it has its own working directory, independent of (but 
initially equal to) that of the process.">,
+  Values<"real,physical">;
 def imultilib : Separate<["-"], "imultilib">, Group<gfortran_Group>;
----------------
sammccall wrote:
> Mea culpa: naming these `physical`/`real` doesn't really explain either the 
> implementation difference nor the observable effect.
> (I thought this internal name didn't matter much and didn't want to rename 
> `getRealFilesystem`...)
> 
> Can we avoid propagating these bad names further? Maybe instead something 
> like `-os-workdir` or `-workdir=os|virtual` or similar?
Maybe? What do other folks who actually tough VFS think? I'm happy to go either 
way, I was following what seemed to be the prevalent naming (and parroted the 
comments on those functions) but I understand that it might not have been 
naming that you thought would leave those function 🙂


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D65986/new/

https://reviews.llvm.org/D65986



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to