kpn marked an inline comment as done. kpn added inline comments.
================ Comment at: include/llvm/IR/IRBuilder.h:113 + CR_ToZero ///< This corresponds to "fpround.tozero". + }; + ---------------- rjmccall wrote: > Should these have "FP" in the name somewhere? And are they really > IRBuilder-specific concepts, as opposed to something that should be declared > as part of the interface for working with these intrinsics? > > Also, I believe we can use explicit underlying types now in LLVM; it'd be > nice if we didn't make `IRBuilder` unnecessarily large. Would it be better to use the RoundingMode and ExceptionBehavior enums in the ConstrainedFPIntrinsic class? These enums->strings here get turned back into those IntrinsicInst.h enums eventually anyway. But that means pulling in yet more headers in IRBuilder.h. I admit I'm not sure what you mean with your second paragraph. Is that a way of saying that, for example, the relevant IntrinsicInst.h enums should be used instead? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D53157/new/ https://reviews.llvm.org/D53157 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits