balazske marked an inline comment as done. balazske added a comment. Thanks for reviewing.
Similar additions are planned to follow with function and variable template, enum, scoped enum, typedef, type alias. ================ Comment at: unittests/AST/ASTImporterVisibilityTest.cpp:34 }; +struct GetClassPattern { + using DeclTy = CXXRecordDecl; ---------------- shafik wrote: > `GetCXXRecordPattern` feels more consistent. The exact decl name is not repeated in these variable names like "FunPattern" for functions. Using "class" instead of "CXXRecord" can be acceptable. I do not like `ImportCXXRecordsVisibilityChain` (`GetRecPattern` and `ImportRecordsVisibilityChain` may be good too, but we do not say "C++ record" for thing that is a class). Repository: rC Clang CHANGES SINCE LAST ACTION https://reviews.llvm.org/D62312/new/ https://reviews.llvm.org/D62312 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits