Charusso accepted this revision.
Charusso added a comment.
This revision is now accepted and ready to land.

What about "the most derived class" or "a superclass" instead of "the 
superclass"? (https://en.cppreference.com/w/cpp/language/derived_class) 
May the sentence is a little bit too long. It would be cool to say "by `A`" or 
something more simple and precise.



================
Comment at: clang/lib/StaticAnalyzer/Core/CoreEngine.cpp:223
+    // But only if we're actually skipping the virtual constructors.
+    if (L.getDst() == *L.getSrc()->succ_begin()) {
+      ProgramPoint P = L.withTag(getNoteTags().makeNoteTag(
----------------
I think it is better to reduce the number of `if`s and merge the related 
comment as it emphasizes there is //only one thing// happen.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D61817/new/

https://reviews.llvm.org/D61817



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to