aaron.ballman accepted this revision. aaron.ballman added a comment. This revision is now accepted and ready to land.
LGTM aside from some minor nits. Thanks for this! ================ Comment at: clang/include/clang/Sema/ParsedAttr.h:896 + void takeOneFrom(ParsedAttributes &attrs, ParsedAttr *attr) { + attrs.getPool().remove(attr); ---------------- How about `Attrs` and `PA` to fit with usual naming conventions? ================ Comment at: clang/test/SemaObjC/arc-property-decl-attrs.m:291 + +id i1, __weak i2, i3; ---------------- Can you add a comment here that explains what this test is intending to cover? Repository: rC Clang CHANGES SINCE LAST ACTION https://reviews.llvm.org/D60101/new/ https://reviews.llvm.org/D60101 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits