hokein added a comment. In D59932#1446533 <https://reviews.llvm.org/D59932#1446533>, @JonasToth wrote:
> I think the idea is good and implementation, too. If we iterate all checks > anyway (probably?) we could think about adding a severity to the checks, too? > > I know that code-checker and code-compass have something like this to signal > importance of problems (say bugprone and cert differ from readability for > example). Thanks. Unfortunately, we have to iterate all checks no matter which solution we use ;( Adding a severity to checks is an interesting idea, we need to define the semantic of the severity, looks like different analyzers define them in different ways (some defined by check quality, like stable enough/production ready; some defined by importance of the problem that the check find). And the existing modules of clang-tidy checks address this problem in some degree (like bugprone, readability modules). I think it is a separate topic that needs more thoughts and discussions. ================ Comment at: clang-tidy/ClangTidyCheck.h:109 + /// not supported. + virtual llvm::StringRef fixDescription() { return ""; } + ---------------- Eugene.Zelenko wrote: > return {} could be used instead. yes, `{}` works here, but I'd use `""` which is more explicit. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59932/new/ https://reviews.llvm.org/D59932 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits