lebedev.ri added inline comments.

================
Comment at: lib/Analysis/ExprMutationAnalyzer.cpp:27
 
+AST_MATCHER_P(Expr, skipCommaOps,
+             ast_matchers::internal::Matcher<Expr>, InnerMatcher) {
----------------
djtodoro wrote:
> lebedev.ri wrote:
> > (Can anyone suggest a better name maybe?
> > I'm not sure this is the most correct name, but i can't suggest a better 
> > alternative.)
> Maybe `evalCommaExpr`?
Ah, yes, `eval` sounds better.
But, it won't always eval comma op or bailout.
It will eval if it is there.
So maybe `maybeEvalCommaExpr` (pun intended!).


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D58894/new/

https://reviews.llvm.org/D58894



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to