riccibruno added a comment. It looks better now as far as I can see. I like the idea of aliasing `SanitizerKind` to `SanitizerMasks<>;`.
================ Comment at: include/clang/Basic/Sanitizers.h:133 // bit positions. enum SanitizerOrdinal : uint64_t { #define SANITIZER(NAME, ID) SO_##ID, ---------------- `SanitizerOrdinal` used to be in `SanitizerKind`. Would it make sense to keep this by moving it to `SanitizerMasks` ? ================ Comment at: include/clang/Basic/Sanitizers.h:169 -} // namespace SanitizerKind +// Force instantiate here to ensure correct initialization order. +template struct SanitizerMasks<>; ---------------- "Force instantiate here [...]" -> "Explicit instantiation here [...]" ? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D57914/new/ https://reviews.llvm.org/D57914 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits